Jump to content

Trying to run the original Blood on XP...


D3ads
 Share

Recommended Posts

Yes it's an old game, bite me.

I've tried using DOSBOX but it runs really slow, if I increase the cycles it speeds up but the sound is garbled and I seem to be stuck with the lowest res as when I change it to 800x600 the program crashes. Looking on the forums turns up information that relates to this method:

http://buildxp.deathmask.net/

There's an awful lot of programs and drivers for that that need to be installed and I'm not sure about any of them, does anyone know if it's ok to go through with that? Last thing I want is a confliction with stuff that runs new games and software...

Failing that, has anyone else successfully ran Blood on DosBox? I tried running the game in Cprompt but it crashes back to desktop...

Any help you can give would be great, ta.

Link to comment
Share on other sites

I played with dosbox. Despite the horrible framerate it gave a little more authentic feeling to it because I had a slow computer that time so it worked just like in the old days. :D

And I also noticed how awful and sick game Blood is. Really I couldn't play it 10 minutes longer because playing it made me feel sick. :(

Link to comment
Share on other sites

I played with dosbox. Despite the horrible framerate it gave a little more authentic feeling to it because I had a slow computer that time so it worked just like in the old days. :D

And I also noticed how awful and sick game Blood is. Really I couldn't play it 10 minutes longer because playing it made me feel sick. :(

Blood Shareware scared me when it first came out, I think it was the music :oops: I payed it more interest because everyone was raving about Quake at the time and I found that boring (at the time) and Blood was just so different from all the other FPS's I'd played and I loved it, never got the full game until now because you can download it from Newgrounds (but you don't get the cut scenes.. heh).

Link to comment
Share on other sites

  • 2 weeks later...

So now I'm onto Blood 2, I found that the menus and intro movies just appeared as black screens with the sound so I disabled Vsync (as suggested on an old forum post on planetblood) and that seemed to fix it, unfortunately it also makes sentences chop-off and cutscenes are rediculously fast..

Any ideas? :?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • MapCore on Discord

  • Our picks

    • Post in Yanzl's Source Emporium
      Two new asset releases!

      First up is Basalt. Sadly I can't release all of the assets as some of the nature stuff is from Megascans and can't be redistributed. Also only includes the assets I've made.


      https://www.dropbox.com/s/e86kdqwpvhhs5x6/Basalt.zip?dl=0

      Second one is assets I've made for Pitstop. A small release that includes some road and concrete trim textures, a bunch of sponsors and some skybox buildings that might be useful.


      https://www.dropbox.com/s/x6tn3b6nfo2u77d/Pitstop.zip?dl=0

      As always, free for non-commercial use with attribution. 
×
×
  • Create New...