Jump to content
Sign in to follow this  
FMPONE

Source 2 Hammer Bugs

Recommended Posts

Importing source 1.0 vmf maps doesn't appear to work, or is at least 64 times too small, and even in that case, the texture coordinate data seems corrupt/random

ZmHuaV8.png

KRF1IpC.png

gf7dI8f.png

YUOZY8T.png

 

Share this post


Link to post
Share on other sites

After tying mesh to and entity, it automatically gets the trigger materials assigned and you cannot assign a different materials to it, which breaks functionality for some mesh entities such as trigger_traversal_no_teleport.

Share this post


Link to post
Share on other sites
On 5/22/2020 at 1:38 PM, marnamai said:

Grid snap is not respected when extruding an object by scaling an edge selection while using a custom workplane.

Can't you just extrude the edge a bit, then just snap move it to where you want?

I always do that by default. 

Share this post


Link to post
Share on other sites
4 hours ago, untor said:

Hotkeys do not work if you used a different keyboard language. (For example Russian). It's funny, but in other software everything works well. Solution, change the language to English on you're keyboard

Ridiculous, but not surprising from Valve. I think even CSGO was switching to American keyboard layout until last year. It's something they never cared about, and it's so basic it's infuriating.

Share this post


Link to post
Share on other sites
9 hours ago, blackdog said:

... I think even CSGO was switching to American keyboard layout until last year. It's something they never cared about, and it's so basic it's infuriating.

What do you mean exactly? I've always used a non-American keyboard layout and don't recall ever having any issues when playing CSGO.

But not having the option to change key binds in S2 Hammer is what annoys me most at the moment. It's especially weird since it seems like you can edit keys (the key bind options have an "apply" button).

I have Z instead of W and so when I press forward in the viewport I enable/disable  "fly toggle".

The way I use for navigating in the viewport in old Hammer unfortunately doesn't work anymore (which includes space bar, LM/RM and scroll wheel), I'm guessing because space bar has been assigned a new use.

Share this post


Link to post
Share on other sites

@Squad at least with Italian layout, the keyboard would not recognise the chars assigned to our layout, so you open the chat to message and you have to know/remember that question mark is underscore for eg.

They basically always had an hard coded override of the layouts or something, which make no sense.

Share this post


Link to post
Share on other sites
4 hours ago, blackdog said:

@Squad at least with Italian layout, the keyboard would not recognise the chars assigned to our layout, so you open the chat to message and you have to know/remember that question mark is underscore for eg.

Oh yeah, that may have been a thing in (early days of) goldsrc CS. I remember having to learn to type qwerty on an azerty keyboard, lol.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...