Jump to content
MikeGon

CSGO - Questions about custom loading screen

Recommended Posts

Hey guys! 

I've been having problems with my loading screen for my map since the Panorama update:

image.png.7f642a5c14f17762b724d5ebf8ccac71.png

I have 3 questions in regards to this. I have searched around but couldn't find an answer...

  • How come my loading screen background image has stopped displaying since the Panorama update? (Both on my machine and other's machines)
  • How come the top down map has stopped displaying since the Panorama update? (Only on other's machines)
  • How can I add a logo for my map at the top right, like official maps usually have?

Cheers, and Thanks in advance! ❤️

Share this post


Link to post
Share on other sites

I just downloaded your map from the workshop and the loading screen works :D

What i observed after the panorama update is that some .dds radars made with gimp had the colours changed to some yellow and purple combinations.

Edited by Serialmapper

Share this post


Link to post
Share on other sites
12 hours ago, Serialmapper said:

I just downloaded your map from the workshop and the loading screen works :D

What i observed after the panorama update is that some .dds radars made with gimp had the colours changed to some yellow and purple combinations.

Huh? So that would mean the problem was with the PC which I downloaded and tested it on... I'll look at it again tonight just to make sure, but that would mean question#1 and #2 are solved 😅

...and for my last question, do guys know how I could add my map symbol to the loading screen? Just like this:

image.png.c322b40ff2b16b1101e02ca585a1ae98.png

The logo is done since a long time ago, but I never found out how to put it there 😐

 

Share this post


Link to post
Share on other sites
On 11/13/2018 at 1:47 AM, MikeGon said:

How come the top down map has stopped displaying since the Panorama update? (Only on other's machines)

In my experience the (packed) radar doesn't show on the first time loading the map. If you load the map again, it's mostly fine.

On 11/13/2018 at 1:47 AM, MikeGon said:

How come my loading screen background image has stopped displaying since the Panorama update? (Both on my machine and other's machines) 

I would like to know, too.

Share this post


Link to post
Share on other sites

As far as we know, adding map crests to non-official maps is impossible, the map crests for official maps are hard coded in the game to go to their specific map file name. Just like certain voice lines for different factions, maps crests must be manually added for each map and have a separate line of code.

Share this post


Link to post
Share on other sites
On 11/13/2018 at 1:47 AM, MikeGon said:

How come my loading screen background image has stopped displaying since the Panorama update? (Both on my machine and other's machines)

Do you have a  loading screen image (named "yourmapname.jpg") in your csgo/maps folder? Eventually CS:GO used the workshop thumbnail ("preview image") as loading screen image before and now you need a separate image(?)

Just guessing, didn't test anything...

Edited by Radix

Share this post


Link to post
Share on other sites
On 11/16/2018 at 5:24 AM, esspho said:

In my experience the (packed) radar doesn't show on the first time loading the map. If you load the map again, it's mostly fine.

Ok thanks, that's reassuring!

 

On 11/17/2018 at 4:32 AM, fewseb said:

As far as we know, adding map crests to non-official maps is impossible, the map crests for official maps are hard coded in the game to go to their specific map file name. Just like certain voice lines for different factions, maps crests must be manually added for each map and have a separate line of code.

hmm really? I thought I saw crests on some of you guys maps... maybe I'm dreaming 🤨

 

On 11/17/2018 at 2:13 PM, Radix said:

Do you have a  loading screen image (named "yourmapname.jpg") in your csgo/maps folder? Eventually CS:GO used the workshop thumbnail ("preview image") as loading screen image before and now you need a separate image(?)

Yep. Everything is set up properly, I know because its working for a long time, and I didn't touch it since...

and according to @Serialmapper, the background image is fine on others' machines.... its so weird

 

Are any of you guys experiencing the same issue other than @esspho ?

If nobody knows the solution to this, then I guess we just have to wait for Valve to send some kind of fix...

Share this post


Link to post
Share on other sites
On 11/27/2018 at 7:57 PM, MikeGon said:

Are any of you guys experiencing the same issue other than @esspho ?

If nobody knows the solution to this, then I guess we just have to wait for Valve to send some kind of fix...

Yeah, this is probably something that the guys at Valve will have to fix.

At first I didn't notice it because my de_austria workshop submission still works for me. But when loading any other workshop map from other people, it doesn't load overview+background.

Overview image: Only works if I have the radar file in my overviews folder (= official maps (including agency, austria, biome and subzero) + my other maps).

Background image: Only 'official' maps (including the 4 community maps).

Also noticed this error in console:

Error reading file materials/panorama/images/map_icons/screenshots/1080p/workshop/*map ID*/*map name*.png

 

So maybe they have added something new, that we don't know, or they have added a bug...

Edited by Radix

Share this post


Link to post
Share on other sites
8 hours ago, MikeGon said:

Ok thanks, that's reassuring!

 

hmm really? I thought I saw crests on some of you guys maps... maybe I'm dreaming 🤨

 

Yep. Everything is set up properly, I know because its working for a long time, and I didn't touch it since...

and according to @Serialmapper, the background image is fine on others' machines.... its so weird

 

Are any of you guys experiencing the same issue other than @esspho ?

If nobody knows the solution to this, then I guess we just have to wait for Valve to send some kind of fix...

Some mappers, including me, make crests for our maps to go with the screenshots and other promotional stuff, but it never appears in game unfortunately.

Share this post


Link to post
Share on other sites
11 hours ago, fewseb said:

Some mappers, including me, make crests for our maps to go with the screenshots and other promotional stuff, but it never appears in game unfortunately.

Well, looks like this is another thing we'll have to wait for Valve for... Add it to the list 😆

 

Thanks guys, I hope something will move soon on that topic!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×