Jump to content
Sign in to follow this  
Pancakesandsyrup123

[CSGO][SOLVED] Is it possible to deactivate hints and arealportals in-game?

Recommended Posts

Hi! I'm having an issue with creating the radar for my map de_retail (previously de_mall but I changed it), because when I type in cl_leveloverview (number) parts of my level are not being rendered, but I believe that is due to the hint brushes that I recently placed. Is there a way to deactivate them or toggle off their effects in game? Because I would like to have the full level rendered for the radar :) Thanks for your attention, and good luck to everyone in the contest!

Edited by Pancakesandsyrup123

Share this post


Link to post
Share on other sites

Probably not. Hint brushes tell the compiler how to cut vis leafs, so there's nothing dynamic about them. With a bit of tweaking of scale and camera location you can normally get everything to show up, but it can be time consuming.

FYI, you should put these questions in your WIP thread or in the 3D forum rather than "Gaming Discussion".

Share this post


Link to post
Share on other sites
3 hours ago, text_fish said:

Probably not. Hint brushes tell the compiler how to cut vis leafs, so there's nothing dynamic about them. With a bit of tweaking of scale and camera location you can normally get everything to show up, but it can be time consuming.

FYI, you should put these questions in your WIP thread or in the 3D forum rather than "Gaming Discussion".

Okay, thanks I'll do that next time :) 

3 hours ago, poLemin said:

I think "r_novis" is the console command you are looking for. It disables the vis-system and renders the entire map at once.

Thanks! That's exactly what I needed :D 

Share this post


Link to post
Share on other sites
5 hours ago, CaptainR3sPawN said:

You have a few options but I don't think you can disable it after a compile;

Remove them and recompile under a new map name, or when in the mode, try and move your mouse around a little bit, it may start rendering other areas, this was always buggy for me but that would usually solve the issue

I am actually stumbling across every possible bug right now, would you please like to help me with this issue? This is happening to me now:

I'm sorry for begging, but I am really short on time and I really want to be in the contest :( 

bigissue - converted with Clipchamp.mp4

Edited by Pancakesandsyrup123

Share this post


Link to post
Share on other sites
1 minute ago, CaptainR3sPawN said:

Was this problem BEFORE using "r_novis" / doing what I said? because I clearly said to do this under a new map name as you don't break your current one.

If this has nothing to do with our solutions, you probably didn't use hint/skips properly.. if you don't reaaalllly know what you're doing, (I don't either when it comes to those) you should probably not try and optimize your map when you have just over 24 hours left... 

Thanks, and you're right, I'm not an expert at mapping.

I believe this also happened before using "r_novis", but I didn't realize it until I set the graphics (shader detail) to high, because that's when it's most apparent. As you can see in the video, when I change back to low settings, it's less noticable.

However, someone else suggested it was due to many expensive textures/ textures with high shadow complexity. I still don't really know the issue, but I will gladly take your advice into consideration :) 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...