Jump to content
Simonay

[CS:GO] My map crashes the game on spawn

Recommended Posts

Hi all,

First time posting here in a looooong time, forgive me if this is in the wrong forum.

That aside, I've found a strange problem with my map in that it appears to compile perfectly well but crashes after you pick a team. Sometimes the crash will be instant, other times it may take a few seconds. It also crashes if you try to spectate.

I've tried recompiling the same vmf having undone as many changes I can think of (side note: TIL to make regular backups) that may have caused the crash but to no avail. The map runs a custom game mode but it also crashes when choosing other modes so I don't think this is an issue. The problem persists whether it's a fast or normal compile. I've also double checked the spawn positions but none seemed to be out of place.

It's a very much complete map so I find it odd this is happening right now. I have a few very old versions I can go back to and restart from but I'd rather save the time and try to fix the current version.

I've included the most recent compile log (from a fast compile) if this is any help.

https://pastebin.com/jS43MPni

Thanks in advance to everyone!

Share this post


Link to post
Share on other sites

Something I like to do is to cut my map up in 4 quadrants and then I compile them in separate vmf files, this way I can find the error by narrowing down the area where the crash occurs.

 

Repeat the cutting of quadrants until you end up with your crasher!

Share this post


Link to post
Share on other sites
10 hours ago, Vaya said:

are the spawns touching the ground?

Nope, 16 units above from foot to floor.

10 hours ago, Lizard said:

Re-generate nav mesh

I'll give this a try and report back tomorrow, thanks for the suggestion.

7 hours ago, maxlevelboi said:

Something I like to do is to cut my map up in 4 quadrants and then I compile them in separate vmf files, this way I can find the error by narrowing down the area where the crash occurs.

 

Repeat the cutting of quadrants until you end up with your crasher!

Splendid idea! Likewise with what Lizard said I will give that a try as soon as I get back to work tomorrow, many thanks.

Share this post


Link to post
Share on other sites

 

14 hours ago, Simonay said:

Nope, 16 units above from foot to floor.

I'll give this a try and report back tomorrow, thanks for the suggestion.

Splendid idea! Likewise with what Lizard said I will give that a try as soon as I get back to work tomorrow, many thanks.

Actually, you should use the cordon tool for that, no need to work with seperate vmf's at all. Just divide the map in half using the cordon tool > compile > check ingame. If it doesn't crash, move the cordon to the other half and check that part. If it crashes, make the cordon box half its size and repeat the process.

Also, I'm not sure what the minimum distance between spawn entities and ground should be, but 16 might be kinda narrow. Don't be afraid to move them up like 64 units or so (if there's no ceiling in the way, that is).

Edited by Squad

Share this post


Link to post
Share on other sites
3 hours ago, Squad said:

 

Actually, you should use the cordon tool for that, no need to work with seperate vmf's at all. Just divide the map in half using the cordon tool > compile > check ingame. If it doesn't crash, move the cordon to the other half and check that part. If it crashes, make the cordon box half its size and repeat the process.

Also, I'm not sure what the minimum distance between spawn entities and ground should be, but 16 might be kinda narrow. Don't be afraid to move them up like 64 units or so (if there's no ceiling in the way, that is).

I did not know that tool existed! Thanks for the tip : D

Share this post


Link to post
Share on other sites

Hi all, thanks for the responses!

I've found the source of the problem to be the func_breakable_surf entities I've been using for windows - compiling the map having removed the windows fixed the crashing so this must be the issue. I remember changing the texture on them before the most recent save so this is shouldn't be too hard to fix.

Now, It's getting late and I'm travelling tomorrow so I'll get to work on a fix asap, assume my lack of further responses to mean my problems are solved!

Thanks again to you all for the help.

Share this post


Link to post
Share on other sites

func_breakable_surf only works with the intended materials from Valve, sadly. Try not to use different textures on it, or parenting it to anything.

Good thing you were able to solve it!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...