Jump to content
rocky

NEED URGENT HELP! Vital map error.

Recommended Posts

Hey guys,

So I have been working on a CityRP map for quite some time for Garry's Mod. Everything was fine until one time I compiled the map and there was 0 light being let into my map apart from the skybox that appeared to be lit up. Normal light entities don't even emit light anymore.

There is a temporary fix for it (compiling on fast mode in expert) but it casts random black blotches over the map, here are screenshots, help is GREATLY appreciated!

First screenshot

Second screenshot

Share this post


Link to post
Share on other sites

Make sure you have a light_environment in the level. Also, it might be worth moving the whole map into another .vmf file and trying to recompile that. It may fix the "black blotches" issue. I had something similar before.

Heres a link to the thread I posted a while ago when I was having the same issue as you, might be of use:

 

Share this post


Link to post
Share on other sites

@rocky Do you have a 3D Skybox ?

Any object in the 3D Skybox that cast shadows will have its shadow projected from the 3D Skybox to the map.
I just made a drawing to show what exactly it means :

F6wNnsH.png

Therefore, if your 3D Skybox is not properly placed, an object could cast a huge shadow on your map.

Or maybe as Plat said there's just no light_environment ... ^^

Share this post


Link to post
Share on other sites

inb4 forgot to check the light entities in the visgroup.

Send your compile log m8

(More seriously, could be a T-Junc error)

Edited by RaVaGe

Share this post


Link to post
Share on other sites

Could also be some light entity inside basic brush.

 

Compile log over pastebin or something would be very helpfull.

Share this post


Link to post
Share on other sites

×
×
  • Create New...