Jump to content
Sprony

Day of Infamy Mapping Contest Discussion

Recommended Posts

Appreciated @Squad my 'fix' for playtest was func_detail the whole building. But i have heard of  "r_hunkalloclightmaps 0" while looking for a fix, cheers for a reminder in some sence.

I do have alot of displacements if thats the issue then... errrr... its something i can't avoid too much.

 

Thanks for the guidance, errors eh ... :)

Share this post


Link to post
Share on other sites

Does anyone have an explanation for how spawnzones work?

 

I have 2 sets of spawnzones, spawn points and blockzones in my map, which I want to change once the middle objective is captured. I've copied the offensive example file, but there's nothing in there to say when the spawns change, just this:

"disablespawns" "1"
"0"  "spawnzone_offensive_a"
"1"  "spawnzone_offensive_b"
"2"  "spawnzone_offensive_c"

 

What are the 0, 1 and 2 even for? Can it be set up in Hammer? I've set one of the spawnzones to be disabled by default, but bots are still spawning in there when the map starts.

Share this post


Link to post
Share on other sites

@

the0rthopaedicsurgeon

you can decompile one of my maps if you want, i had the same problems first.

you need to setup the most things in hammer.

to define spawns you need the spawnpoints and a spawnarea.

in the flag header of the spawnpoints you will need to setup bind to spawnarea (or something like this named).

you will need to name the spawns in the cronological way you want to enable them.

If you want you can add me on steam - name ("Modtools" or "Madtec")

 

 

@ DEVs:

One question. I have made a custom loading screen but if i pack it in the right place of the directories and pack it with vide into the .bsp file it does not show ingame after uploading.

How can i insert my custom loadingscreen into the map ?

 

Thx in advance.

Hope you will like my last update of westwall.

Gz Modtools

Share this post


Link to post
Share on other sites
On 19-11-2016 at 0:05 AM, the0rthopaedicsurgeon said:

Does anyone have an explanation for how spawnzones work?

 

I have 2 sets of spawnzones, spawn points and blockzones in my map, which I want to change once the middle objective is captured. I've copied the offensive example file, but there's nothing in there to say when the spawns change, just this:

"disablespawns" "1"
"0"  "spawnzone_offensive_a"
"1"  "spawnzone_offensive_b"
"2"  "spawnzone_offensive_c"

 

What are the 0, 1 and 2 even for? Can it be set up in Hammer? I've set one of the spawnzones to be disabled by default, but bots are still spawning in there when the map starts.

In Offensive, the "0" represents the starting conditions (attacking team needs to capture A). When they captured that, the spawns linked to "1" become active. And so on until the attackers are at C (or D).

Make sure to disable all spawns by default. The game controls which ones become active and at what point in the game.

Share this post


Link to post
Share on other sites

Hi guys I have small issue with hammer right now.
 

YjLHeXt.jpg
GtYyqRy.jpg

A gif:

https://giphy.com/gifs/3o7TKCXxgn6FvhKwuY

 

 

As you can see my entities are disappearing at certain distance. The wieirdest thing is that this distance is different for few models.
My 3d settings in hammer:
9laKpXB.png

AiBQeDj.png

Any ideas?

 

Edited by Lizard

Share this post


Link to post
Share on other sites
54 minutes ago, zastels said:

I didn't see you added the top bar at the very bottom of all the pictures. Is it possible the detail controller entity is causing this? 

 

Edit: If these are custom models, do they come with LOD's, and are they set properly?

It was fine before I formatted my PC 3 days ago.

~~EDIT~~
SOLVED
zH0GXJE.png

It was Screen space object culling option exclusive for Insurgency/DoI hammer i guess...
 

Edited by Lizard

Share this post


Link to post
Share on other sites

Hello everyone!

 

Does anyone know if source batch compiler works with DOI and Insurgency?

And also, I still have the purple texture / specularity problem. I cant seem to solve it permanentely. 
Everytime I run my map I have to do mat_spec 0, build cubemaps and then mat_spec 1. Is there a fix to this?

Edited by GRiNET

Share this post


Link to post
Share on other sites
1 hour ago, zastels said:

I've never seen actual proof you need to mat_spec anything.

 

To build cubemaps properly you must take these steps.

 

Step1: build cubemaps

Step2: Close and open game again (You can not avoid doing this in DOI, only in CSGO) 

Step3: You must pack your cubemap files into the .bsp before you upload to the workshop, I use pakrat it automatically does it.

 

 

My understanding is that mat_specular 0 disables reflections. Therefore, the only time you would see an issue is if you ran buildcubemaps while there were already existing cubemaps for the map - in which case you would see reflections within your reflections.

Share this post


Link to post
Share on other sites

Hello lads. I've encountered another problem. 

Whenever I try to paint alpha on my discplacement brusches on the ground hammer crashes, no error or anything just straight to desktop. The texture I am using is called: de_mirage/ground_de_tileh_blend3_diffuse. Is it something wrong with the texture or is it me?

Share this post


Link to post
Share on other sites

I think it may not like painting with a diffuse,  just a guess.  I   I paint alpha all the time, no problems but I've never used a diffuse texture.  Maybe try another blend that's not a diffuse..

edit - Just tried your texture, no problem.  Nice looking blend but no crash, sorry.  No ideas, except the diffuse thing.

Edited by mr_ah_clem

Share this post


Link to post
Share on other sites
On 12/3/2016 at 3:50 AM, GRiNET said:

Hello lads. I've encountered another problem. 

Whenever I try to paint alpha on my discplacement brusches on the ground hammer crashes, no error or anything just straight to desktop. The texture I am using is called: de_mirage/ground_de_tileh_blend3_diffuse. Is it something wrong with the texture or is it me?

Are you launching hammer with the .exe or the .bat?  When I was getting crashes in Hammer it was due to the VPROJECT environment being set incorrectly -- which the .bat file resolves each time.

Share this post


Link to post
Share on other sites

×
×
  • Create New...