Jump to content
Guest

[csgo] Lighting on props broken since Wildfire Update? (+ Possible fix)

Recommended Posts

Why do you need a shadow_control entity ?
It was used in Half-Life 2 and other games, when the dynamic shadows were only possible with dynamic/physics objects (they were very simple projections, not real projected shadows). But on CSGO, since the only dynamic shadows you can have are due to the cascaded shadows (for outside areas), it became useless. (i think)

Share this post


Link to post
Share on other sites

As I've stated in the Edit, I tried to change the color, but it doesn't affect it at all. 

Ambient is a purple-gray (196 185 208 200 purple0osx6.jpg, very slightly), nothing extreme blueish. I removed all entities but the shadow_control, light_env and it still happens. I changed the shadow color for the shadow_control to 196 196 196 (grey, duh!) and still no change. This screenshot is compiled with HDR only but shows the effect pretty well. And yes, I compile with -StaticPropLighting

Hidden Content

Try to delete your light_env and add a new one with the same settings. That might solve your problem.

Share this post


Link to post
Share on other sites

I already stated in my post before, that it didn't solve the problem. Anyways, I guess I'll fiddle this around with patience. ^^

 

Okay, I've determined the cause of the problem. BrightnessScaleHDR and AmbientScaleHDR both had a value of 0.5. After setting both back to 1, the problem's gone. To be more precise: BrightnessScaleHDR cannot be lower than 1.

Kinda suspected it.

Edited by Deathy
Solution found!

Share this post


Link to post
Share on other sites

both shadow_control and HDR brightness and ambiant values on any light entity are completely useless on CSGO anyway ...

i've noticed that reducing the ambient has an effect on the shadows

brightness is negligible though...

Share this post


Link to post
Share on other sites

i've noticed that reducing the ambient has an effect on the shadows
brightness is negligible though...

Yes of course it will change but it doesn't mean it's useful !
HDR Brightness and HDR Ambient were parameters used when the players had a choice of enabling HDR or not in the video options (on games such as Half-life 2, CSS, DOD:S, TF2 ... most of the Source games). Because then, the lighting of the whole map was compiled twice : once without HDR (↔ "LDR") and once with HDR. The compilation times were doubled, the file sizes of maps were a lot bigger ...

They decided on CSGO to force every user to have the HDR enabled, you can not disable it in video options. Therefore, it's useless to compile your map in LDR (↔ non-HDR), because the players won't be able to see the map this way.

 

HDR brightness and HDR ambiant parameters were used in case you have a light, that was looking good in LDR but too bright (for example) in HDR. It gave you the possibility to adjust the lighting on each version of the map. But if you don't configure the HDR values, it will use the default ones for both lighting compilations.

So yes, if you change the HDR brightness and HDR Ambient values, it will change the lighting on your map but you could also have changed the default brightness and ambiant values, it would also have changed the lighting in the same way.

 

Hidden Content

It did after update. How can I solve this? Thanks. 

It's just a leak or something like that, no lighting is compiled here (it's in fullbright).

Share this post


Link to post
Share on other sites

It's just a leak or something like that, no lighting is compiled here (it's in fullbright).

I put standard lights and light_environment. And I didn't see *.lin (leak) file in my map folder.

My expert parameters:

-staticproppolys -textureshadows -staticproplighting -staticpropsamplescale 16 -game $gamedir $path\$file

Share this post


Link to post
Share on other sites

@Onur Kardelen this could caused by giving names to your lights. If you did so, you can try to delete the name(s) and recompile.

But I connected lights to buttons. When I pressed button, it opens named light. If I delete that names, how can I connect lights to buttons?

Edited by Onur Kardelen

Share this post


Link to post
Share on other sites

Try to delete your light_env and add a new one with the same settings. That might solve your problem.

I made some tests with the light_env. To me it seems that to intense light causes that problem. You can even change the colour of the strange shadow by selecting another ambient color. If no ambient colour is selected the strange shadow just remains black.

Any other ways of compiling, even final, did not fix it for me.

I lowered the brightness to a much lower value and got rid of these shadows.

strange shadows.jpg

Edited by Shibou
forgot something

Share this post


Link to post
Share on other sites

But I connected lights to buttons. When I pressed button, it opens named light. If I delete that names, how can I connect lights to buttons?

Unfortunately there is no work around for this. I noticed that since the wildfire update switchable lights can cause this kind of thing you are having. I had a similar problem recently and got rid of it by replacing the lights with just env_sprites that can be turned on and off. It works okay in my case - hope that helps.

 

PPotl9u.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...