Jump to content
Guest

[csgo] Lighting on props broken since Wildfire Update? (+ Possible fix)

Recommended Posts

Is anyone else having problems with HDR? All of my compiles are turning up with blue shadow highlights. The only solution I have found is compiling without HDR.

Hidden Content

This problem was solved by removing the light_environment and adding a new light_environment with the exact same settings. Looks like the entity was somehow corrupted. Funky stuff.

Share this post


Link to post
Share on other sites

This problem was solved by removing the light_environment and adding a new light_environment with the exact same settings. Looks like the entity was somehow corrupted. Funky stuff.

Can confirm this does not work (for me). Still have solid dark shadows with occasional blue bits on props and when viewing shadows at a very shallow angle from large distance.

Edited by jackophant

Share this post


Link to post
Share on other sites

Can confirm this does not work (for me). Still have solid dark shadows with occasional blue bits on props and when viewing shadows at a very shallow angle from large distance.

I had the same problem here.
I fixed it, by removing the light_directional,...try to do it, if you have one. 

This is sad. :sad:

 

Share this post


Link to post
Share on other sites

I had the same problem here.I fixed it, by removing the light_directional,...try to do it, if you have one. 

This is sad. :sad:

Ah, yeah I'll give that a shot.

I have to put my hands up and say I don't actually understand what the light_directional is meant to do. It seems to fulfil similar/same role as light_environment.

I only have it due to taking lighting from another map and didn't take the time to understand what it does. Documentation on it is pretty barren as well.

Share this post


Link to post
Share on other sites

Added  -StaticPropLighting -StaticPropSampleScale 0.25 to $light_exe parameters in "fast" option in expert compile and this error appear when compiling:

Command line: "E:\Steam\steamapps\common\Counter-Strike Global Offensive\bin\vrad.exe" "-bounce" "2" "-noextra" "-game" "E:\Steam\steamapps\common\Counter-Strike Global Offensive\csgo" "e:\steam\steamapps\common\counter-strike global offensive\sdk_content\maps\de_industry" "-StaticPropLighting" "-StaticPropSampleScale" "0.25"
usage  : vrad [options...] bspfile
example: vrad c:\hl2\hl2\maps\test

And vrad crashes.

How I can fix it? :c

 

Edited by Aztk

Share this post


Link to post
Share on other sites

put the options before the BSP file

 

-bounce" "2" "-noextra" 
 "-StaticPropLighting" "-StaticPropSampleScale" "0.25"
 "-game" "E:\Steam\steamapps\common\Counter-Strike Global Offensive\csgo" "e:\steam\steamapps\common\counter-strike global offensive\sdk_content\maps\de_industry" 

 

or something like that. not 100% on this syntax as i don't touch these often.

Share this post


Link to post
Share on other sites

Ah, yeah I'll give that a shot.

I have to put my hands up and say I don't actually understand what the light_directional is meant to do. It seems to fulfil similar/same role as light_environment.

I only have it due to taking lighting from another map and didn't take the time to understand what it does. Documentation on it is pretty barren as well.

light_directional is like the twin of env_cascade_lighting, the entity that controls the cascade shadow mapping (super accurate real time shadows). The light_environment is what casts the light and sets angles and the other two are what control the shadow maps. 

Saying that, I don't actually think they're necessary to have because the shadow maps get generated without either of the entities.  

Edited by sevin

Share this post


Link to post
Share on other sites

light_directional is like the twin of env_cascade_lighting, the entity that controls the cascade shadow mapping (super accurate real time shadows). The light_environment is what casts the light and sets angles and the other two are what control the shadow maps. 

Saying that, I don't actually think they're necessary to have because the shadow maps get generated without either of the entities.  

Good to know, thanks :) 

Share this post


Link to post
Share on other sites

I don't even have a light_directional, only have light_environment, sunlight_shadow_control and shadow_control and have the same problem as MaanMan (blue tinted dynamic shadows with fade to black borders).

Edit: I tried RZL's suggestion, light_env replacement didn't work. Compiling LDR/HDR seperately showed, that it's definitely on the HDR part. I tried to find out whether it might be affected by the shadow color specified in the shadow_control entity but it produces the same results.

Edited by Deathy
troubleshooting

Share this post


Link to post
Share on other sites

I don't even have a light_directional, only have light_environment, sunlight_shadow_control and shadow_control and have the same problem as MaanMan (blue tinted dynamic shadows with fade to black borders).

Edit: I tried RZL's suggestion, light_env replacement didn't work. Compiling LDR/HDR seperately showed, that it's definitely on the HDR part. I tried to find out whether it might be affected by the shadow color specified in the shadow_control entity but it produces the same results.

What is your ambiant value ?

Cascaded shadows used to be only grey, it was impossible to color them. Shadows were only colored in their static areas (in the lightmaps), that's why we had this weird blending between static and dynamic shadows before.

Now, they should be the same, so maybe your ambiant is just too colorful/surrealist ?

Check this out : http://blog.counter-strike.net/workshop/maps.php#cascade_shadow (it's all new ! <3)

 

EDIT : Or maybe the other entities (sunligh_shadow_control and shadow_control) override the light_env ambiant value, but just for static shadows. Try to delete them maybe

Edited by leplubodeslapin

Share this post


Link to post
Share on other sites

As I've stated in the Edit, I tried to change the color, but it doesn't affect it at all. 

Ambient is a purple-gray (196 185 208 200 purple0osx6.jpg, very slightly), nothing extreme blueish. I removed all entities but the shadow_control, light_env and it still happens. I changed the shadow color for the shadow_control to 196 196 196 (grey, duh!) and still no change. This screenshot is compiled with HDR only but shows the effect pretty well. And yes, I compile with -StaticPropLighting

2016-02-25_00001gesfx.jpg

Edited by Deathy

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...