Jump to content
Guest

[csgo] Lighting on props broken since Wildfire Update? (+ Possible fix)

Recommended Posts

Hi there! We released an update to VRAD in the latest update. To get proper lighting on static props, you will need to run with -StaticPropLighting in VRAD, which sadly isn't updated (yet) in Hammer for the default, quick compile settings.

This flag will increase compile times, but to help with iteration we also included the ability to tweak the quality of the new lighting by adding -StaticPropSampleScale x parameter (16 = slow, high quality, 4 = default and 0.25 = fast, low quality) which is useful if you want to speed up compile times. Note that adding -final is the same as having -StaticPropLightingScale 16.

 

We'll have the full documentation for the upgraded compile tools out early next week.

Hey, Is there a reason why azerty is not supported for hammer, will there be a update to support it? I have to change my language everytime I start hammer, and it's getting very annoying for if I have to browse some stuff or talk to friends while working.

Share this post


Link to post
Share on other sites

I had that unpleasant surprise too, seeing all of those prop_static rendered black at fast compile. I was starting to panic and curse Windows. :D 

By the way, on linux the prop_static aren't black at fast compile but are horribly lit with some weird rainbow like effects.

An offtopic question to mr. MagnarJ: will it be possible for Hammer and Cs:go SDK to be ported on Linux? or should i remove that hope? (i'm dual booting just for mapping).

Edited by Serialmapper

Share this post


Link to post
Share on other sites

wait, so all we have to do is add those -staticproplighting and -StaticPropSampleScale # parameters to our fast compile setting and it's all gravy? :D Was sitting here for 30 minutes on a hdr compile. Good thing I came across this post!

Edited by kinggambit

Share this post


Link to post
Share on other sites

For some reason I am having the same problem but the compiling settings did not fix the issue.

The props appear to be in a very dark enviroment, some of them could get back to life by adding light near them (the sculpture in the screenshot), others remained completely black even after setting up lights next to them. But at least the reveal their color if you fire your gun next to them.

 

Anyone else is still haveing the problem and/or a potential fix ?

proptest0000.jpg

proptest0000-hammer.jpg

Share this post


Link to post
Share on other sites

You added it at "additional game parameters", cut it and click on "Expert..."

Now choose the fast configuration in the top left drop down menu. Go to "$light_exe" and paste these parameters there. Then click "GO" to compile.

Edited by baem123

Share this post


Link to post
Share on other sites

You added it at "additional game parameters", cut it and click on "Expert..."

Now choose the fast configuration in the top left drop down menu. Go to "$light_exe" and paste these parameters there. Then click "GO" to compile.

lets face it: that was realy noobish from me.

But it worked and now everything is fine with my map again. Thank you very much!

 

Share this post


Link to post
Share on other sites

Hi there! We released an update to VRAD in the latest update. To get proper lighting on static props, you will need to run with -StaticPropLighting in VRAD, which sadly isn't updated (yet) in Hammer for the default, quick compile settings.

This flag will increase compile times, but to help with iteration we also included the ability to tweak the quality of the new lighting by adding -StaticPropSampleScale x parameter (16 = slow, high quality, 4 = default and 0.25 = fast, low quality) which is useful if you want to speed up compile times. Note that adding -final is the same as having -StaticPropLightingScale 16.

 

We'll have the full documentation for the upgraded compile tools out early next week.

Hello there!

Does the -StaticPropSampleScale x parameter affect the .bsp filesize in any way? My current project just raised around 30-35mb with the latest update and i can't seem to get it down by setting the value to 0.25. I've also tried setting the value to 1 and 4, still ending up with the same filesize.

I'm not sure if i got something wrong, here's my parameter line for $light_exe:
-textureshadows -hdr -StaticPropLighting -StaticPropSampleScale 0.25 -StaticPropPolys -game $gamedir $path\$file

If there is nothing that can be done about the increase in filesize, would it perhaps be possible to use a previous version of vrad.exe? In that case, would you happen to have it available?

I really need to get my .bsp filesize lower due to the community fastDL servers being capped at 150mb.

Share this post


Link to post
Share on other sites

 

With the new Wildfire Update came a whole new Nuke, which included a lot of new assets. So, I go into Hammer and place down a few of the new props, then compile. They're all completely black. I tried to just compile older props from other maps, and they are also all black. Anyone else having this problem?

Pics:

Hidden Content

I have the same problem 

:???:

Share this post


Link to post
Share on other sites

I'm kind of having same problem as @MaanMan, but my shadows cast on the floor are solid black. If they carry on over to a wall, that shadow is fine. I also have odd light reflections on walls and anywhere a light source is, the weird, black, inky shadow disappears.

This has been replicated on @Vaya's machine as well, using his originally non-problematic compile settings:

http://imgur.com/a/dahc0

Share this post


Link to post
Share on other sites

You added it at "additional game parameters", cut it and click on "Expert..."

Now choose the fast configuration in the top left drop down menu. Go to "$light_exe" and paste these parameters there. Then click "GO" to compile.

I did this and now it just crashes my vrad. No clue what's going on.

EDIT: Can someone who got theirs to work give me their settings? I just want to be able to map again without dealing with this. I can't compile anymore without vrad crashing. Thanks valve.

Edited by Plat

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...