Jump to content

Splinter Cell: Blacklist


Recommended Posts

  • Replies 182
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Tom Clancy's Splinter Cell: Blacklist Has Gone Gold   http://www.ign.com/articles/2013/08/08/tom-clancys-splinter-cell-blacklist-has-gone-gold

Plane flying

www.greenmangaming.com

 

Use GMG20-4B9NY-L4FEN voucher.

 

"Unable to add the voucher" :(

 

Edit, I looked it up on google, and that voucher is only valid for the "Tom Clancy's Splinter Cell: Blacklist - Deluxe Edition" and that version didn't come out here in the US, too bad.

Link to post
Share on other sites

www.greenmangaming.com

 

Use GMG20-4B9NY-L4FEN voucher.

I'm still baffled how they do it. Is it 100% legal? Do developers get the same cut as they would through steam or other channels?

From the little I've seen it seems like they recycle copies, thus it's pretty much like a retail store... and fuck retail stores and 2nd hand sales.

 

Anyhow... 2 more days! Wohoow :D

Edited by Chimeray
Link to post
Share on other sites

Opening cinematic stuttered like crazy. It sucks that I wasn't able to tweak the settings before that intro video? I was in windowed mode for some reason, sort of an immersion breaker. Then I got into the game and the whole game feels like it's in slow motion, all the sounds are fine but all animations are weightless and feel slowed down. Is that how it's supposed to be or...? Going home now, gonna try again tomorrow. :/

Link to post
Share on other sites

Opening cinematic stuttered like crazy. It sucks that I wasn't able to tweak the settings before that intro video? I was in windowed mode for some reason, sort of an immersion breaker. Then I got into the game and the whole game feels like it's in slow motion, all the sounds are fine but all animations are weightless and feel slowed down. Is that how it's supposed to be or...? Going home now, gonna try again tomorrow. :/

 

First I've heard of this issue? Update your drivers maybe?

Link to post
Share on other sites

 

Opening cinematic stuttered like crazy. It sucks that I wasn't able to tweak the settings before that intro video? I was in windowed mode for some reason, sort of an immersion breaker. Then I got into the game and the whole game feels like it's in slow motion, all the sounds are fine but all animations are weightless and feel slowed down. Is that how it's supposed to be or...? Going home now, gonna try again tomorrow. :/

 

First I've heard of this issue? Update your drivers maybe?

 

The slowdown seems related to the framerate apparently, sort of like it's trying to catch up to what's happening even though I never drop below 30 and have Vsync off. Anyhow I'm on my work PC, I'll try again tonight on my home PC and be sure to update all drivers and such :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...